Talk service outage
Incident Report for Sound of Data
Resolved
Incident resolved.

If you have any questions regarding this incident, please reach out to our customerservice team at customerservice@soundofdata.nl
Posted Nov 22, 2022 - 13:25 CET
Identified
The issue has been indentified and fixed.
Posted Nov 22, 2022 - 13:21 CET
Investigating
We are currently investigating a problem with our Talk service.

We will update in 30 minutes. If you have any questions regarding this incident, please reach out to our customerservice team at customerservice@soundofdata.nl
Posted Nov 22, 2022 - 13:13 CET
This incident affected: ITSP | Products (Talk).