[Voice] degraded quality via partner network

Incident Report for Sound of Data

Resolved

Incident resolved. Postmortem will follow.
Posted Mar 19, 2026 - 10:18 CET

Update

While we wait for official confirmation of the resolution status we can confirm that our tests are now clean and rerouting efforts have mitigated any remaining issues. We will keep monitoring over the next 6 hours to validate stability.
Posted Mar 18, 2026 - 11:13 CET

Monitoring

We are seeing an improvement in overall stability. also confirmation from the AMS-IX that they had issues around 09.22. Should be fixed now. we are monitoring.
Posted Mar 18, 2026 - 10:21 CET

Update

We are continuing to investigate the issue with out networking partners. We suspect the issue to be related to issue with the ams-ix internet exchange. We are taking further efforts to reroute traffic.
Posted Mar 18, 2026 - 10:16 CET

Investigating

Since 09.10 CET our monitoring systems have identified issues with one of our dutch carriers. Impacted customers may experience degraded audio quality, silence or audio drop outs. We are taking mitigating efforts and have escalated to p1 incident level.

Impacted numbers can be local dutch numbers , dutch toll free numbers, dutch premium rate numbers and possibly a small set of Belgium numbers.

Next update in 15 minutes.
Posted Mar 18, 2026 - 09:42 CET
This incident affected: ITSP | Services (Voice Services).