[Voice] Talkdesk Europe issues

Incident Report for Sound of Data

Resolved

All services are restored and both inbound and outbound voice calls are working for all tenants.
Posted Nov 26, 2025 - 11:57 CET

Monitoring

Talkdesk has implemented fixes and reports all issues should be resolved. We are monitoring and verifying if that is indeed the case.
Posted Nov 26, 2025 - 10:53 CET

Update

If you wish to subscribe to incidents from Talkdesk directly you can follow along here:

https://status.talkdesk.com/incidents/yxxxz3wlt9nk#subscribe-modal-yxxxz3wlt9nk
Posted Nov 26, 2025 - 09:10 CET

Identified

Talkdesk contact center customers in EU are having issues with inbound and outbound voice calls. This is a Talkdesk issue and needs to be resolved by Talkdesk.

Our BYOC trunks are operational, but since the Talkdesk side is broken, there is no way for us to mitigate the issue.

We can help out with emergency messages for inbound calls. If you would like more information about how to do this, please reach out to your account manager.
Posted Nov 26, 2025 - 09:07 CET
This incident affected: MSP | Omnichannel Platforms (Talkdesk).